链眼社区:专注于区块链安全,区块链数据分析, 区块链信息整合,区块链技术服务和区块链技术咨询。

opam init fail

问题描述

opam init No configuration file found, using built-in defaults. Checking for available remotes: rsync and local, git. - you won't be able to use mercurial repositories unless you install the hg command on your system. - you won't be able to use darcs repositories unless you install the darcs command on your system.

<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><> 🐫 Processing 1/1: [default: http]1

1 [ERROR] Could not update repository "default": OpamDownload.Download_fail(_, "Curl failed: \"/usr/bin/curl --write-out %{http_code}\\n --retry 3 --retry-delay 2 --user-agent opam/2.1.2 -L -o /private/var/folders/n8/q0bkzhdn40z5bjb5cgphqsq40000gp/T/opam-25810-9d347f/index.tar.gz.part -- https://opam.ocaml.org/index.tar.gz\" exited with code 56") [ERROR] Initial download of repository failed.

回复区

coinwang 2022-05-24 14:16:27

执行 brew install gpatch 之后重试,应该就能成功

回答

合作伙伴